BlueSnap Logo

Status Page

Phone Service Interruptions

Minor incident BlueSnap Technical Support
2022-05-31 06:58 PDT · 2 hours, 22 minutes, 50 seconds

Updates

Resolved

This issue is now resolved. In the recent 30 minutes, our phones have been working without interruption.

May 31, 2022 · 09:20 PDT
Investigating

We are experiencing technical interruptions with our phone services caused by an issue over our service provider’s end.

We are working with our provider to solve the problem, and we will send out an update once we are back on the phone.

Until this is resolved, our support team is still available via LiveChat and Email - for any question or request.

May 31, 2022 · 08:26 PDT

← Back