BlueSnap Logo

Status Page

Latency with American Express (AMEX) 3DS Authentication

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2022-03-31 20:40 PDT · 12 hours, 54 minutes, 55 seconds

Updates

Resolved

We got a confirmation from Amex that the 3DS issue is resolved (Reported End Date/Time: 01-Apr-2022 08:19 PST).

Customers should no longer experience timeout errors or latency.

April 1, 2022 · 09:34 PDT
Issue

We are seeing latency with American Express (AMEX) 3DS Authentication Service.

AMEX has advised that their engineers are working on a resolution but do not yet have an expected time of recovery. Until the issue is resolved by Amex, customers may experience higher than normal timeouts while processing 3DS authentication on Amex cards.

April 1, 2022 · 07:41 PDT

← Back