BlueSnap Logo

Status Page

Support Response Delays Due to Salesforce Service Disruption

Minor incident BlueSnap Technical Support Pages
2026-09-16 01:30 PDT · 4 hours, 57 minutes

Updates

Resolved

While Salesforce has not yet confirmed full resolution on their end, we are seeing significant improvement in our support operations and no delays are currently being reported. We consider this incident resolved and will continue to monitor for any recurrence.

September 16, 2026 · 06:21 PDT
Issue

We are currently experiencing partial impact on our support operations due to an ongoing Salesforce service disruption.

Our teams remain available and are working to respond to support tickets as quickly as possible; however, some delays may occur while the Salesforce disruption continues.

For urgent issues, please contact us via LiveChat.

We are closely monitoring Salesforce’s status updates and will provide another update once we confirm that the issue is no longer affecting our support operations.

September 16, 2026 · 02:26 PDT

← Back