BlueSnap Logo

Status Page

Intermittent Fraud Prevention Provider Connectivity Issues

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2026-08-06 04:51 PDT · 4 hours, 4 minutes

Updates

Resolved

Connectivity to our fraud prevention provider has been restored, and full fraud prevention service coverage is now operating normally.

August 6, 2026 · 08:55 PDT
Investigating

We have identified intermittent connectivity issues with our fraud prevention provider that might cause increased authentication declines.

We are actively working to restore full fraud prevention service coverage.

August 6, 2026 · 04:51 PDT

← Back