BlueSnap Logo

Status Page

AMEX Settlement Processing Disruption

Minor incident Production Environment - Production: Payout
2026-07-21 03:00 PDT · 3 days, 9 hours, 31 minutes

Updates

Resolved

The issue has been fully resolved. All American Express settlement files have been processed successfully. The RCA is currently underway.

July 24, 2026 · 12:29 PDT
Investigating

We are investigating an issue affecting AMEX settlement file processing, resulting in delays to funding for merchants using AMEX Direct. AMEX file transmissions have been temporarily paused while we work with American Express to resolve the issue.

Merchant payment processing remains unaffected.

July 24, 2026 · 04:04 PDT

← Back