Mastercard 3DS Authentication Timeouts
Minor incident
Production Environment
- Production: BuyNow Hosted Pages
- Production: Web Services (API)
2026-07-15 01:07 PDT
· 1 hour, 24 minutes
Updates
Resolved
July 15, 2026 · 02:31 PDT
The issue causing Mastercard transaction timeouts across the Centinel platform has been mitigated. Services have recovered, and we are closely monitoring performance to ensure ongoing stability.
Investigating
July 15, 2026 · 01:07 PDT
We are currently investigating an issue causing transaction timeouts for Mastercard 3DS authentication. As a result, some Mastercard transactions may experience authentication failures or processing delays.
Our team is working urgently to identify the cause and resolve the issue as quickly as possible.
← Back