BlueSnap Logo

Status Page

Issue with acquiring bank causing some transactions to fail

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2026-06-16 11:56 PDT · 6 hours, 56 minutes

Updates

Resolved

The issue has been fully resolved by the acquiring bank and transaction processing has returned to normal levels.

June 16, 2026 · 18:50 PDT
Issue

An ongoing issue with one of our acquiring banks is causing some transactions to fail with the error “GENERAL_PAYMENT_PROCESSING_ERROR”,”code”:”14002”,”description”:”Transaction failed because of payment processing failure”.

An active investigation is currently under way by the acquiring bank. We are actively monitoring the situation.

June 16, 2026 · 15:56 PDT

← Back