BlueSnap Logo

Status Page

Processing errors (Israel, local acquirer)

Major incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API) Sandbox Environment - Sandbox: BuyNow Hosted Pages - Sandbox: Web Services (API)
2026-04-22 03:48 PDT · 1 hour, 56 minutes

Updates

Resolved

This issue is now resolved. Transaction processing through our Israel processor is now operating normally after a production certificate update.

We’re continuing to investigate the root cause and will share additional details as they become available.

If you have any questions, please contact Support.

April 22, 2026 · 05:43 PDT
Investigating

In the last hour, we’ve been seeing an increase in processing errors with our local acquirer in Israel. Some users may encounter a general decline message when attempting to complete a transaction: “An error occurred. Please try again later.

Our team is actively investigating, and we’ll share another update as soon as we have more information.

Thanks for your patience. If you have any questions, please contact our Support team.

April 22, 2026 · 03:48 PDT

← Back