BlueSnap Logo

Status Page

Delayed Payout Inclusion for Recent Transactions

Minor incident Production Environment - Production: Payout
2026-03-30 04:34 PDT · 1 hour, 32 minutes

Updates

Resolved

We can confirm that all delayed transactions have been accounted for and included into the next scheduled payout cycle.

Please accept our apologies for the delay and feel free to reach out for any further information.

March 30, 2026 · 06:05 PDT
Issue

Due to unexpected consequences of scheduled maintenance, a subset of transactions processed yesterday may not be included in the upcoming scheduled payout.

These transactions will instead be included in the following payout cycle.

For more details please reach out to our support team.

March 30, 2026 · 04:34 PDT

← Back