BlueSnap Logo

Status Page

Ongoing Issue with 3D Secure Authentication Causing Some Transactions to Fail

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2026-03-25 12:00 PDT · 12 hours, 46 minutes

Updates

Resolved

The 3D Secure Authentication issue has been resolved.

Thank you for your patience while we worked to resolve this issue.

March 26, 2026 · 00:34 PDT
Investigating

We are currently investigating an ongoing issue with 3D Secure Authentication which is causing some transactions to fail.

March 25, 2026 · 13:39 PDT

← Back