BlueSnap Logo

Status Page

BlueSnap.com Website Temporarily Unavailable

Minor incident BlueSnap Technical Support Pages
2025-12-19 08:02 PST · 1 hour, 7 minutes

Updates

Resolved

The issue in now resolved. The BlueSnap website https://www.bluesnap.com is back online and fully accessible. We continue to monitor CloudFlare status to confirm the issue does not recur.

December 19, 2025 · 09:05 PST
Issue

The BlueSnap website www.bluesnap.com is currently displaying a Cloudflare error page: Error 526 – Invalid SSL certificate. We are actively investigating and working to resolve this issue as soon as possible. All other systems are running as usual with no impact on transaction processing, payout schedules, reports or notifications.

December 19, 2025 · 08:27 PST

← Back