Issues With Email Delivery System
Minor incident
BlueSnap Technical Support Pages
2025-11-17 11:58 PST
· 2 hours, 38 minutes
Updates
Resolved
November 17, 2025 · 14:35 PST
The issue with BlueSnap’s email delivery system has been resolved and all pending emails have been sent. The RCA is currently underway.
Investigating
November 17, 2025 · 12:53 PST
We are currently experiencing issues with our email delivery system. This is causing delays in delivery of all BlueSnap email notifications.
← Back