BlueSnap Logo

Status Page

Limited Access to Merchant Console on Latest Google Chrome Version

Minor incident Production Environment - Production: SnapConsole Sandbox Environment - Sandbox: SnapConsole
2025-11-07 07:00 PST · 2 days, 21 hours, 11 minutes

Updates

Resolved

We’re pleased to inform you that full access to the BlueSnap Merchant Console has been restored.

The previously affected Payout Method and Webhook pages under the Settings menu are now fully accessible and functioning as expected.

Our R&D team has implemented the necessary fixes, and we continue to monitor system performance to ensure ongoing stability.

Thank you for your patience and understanding while we worked to resolve this issue.

November 10, 2025 · 04:10 PST
Investigating

We’ve identified that the Payout Method and Webhook pages under the Settings menu remain temporarily inaccessible. Our R&D team continues to work on resolving these remaining issues.

All other areas of the console are fully functional, and we will provide another update as soon as full access is restored.

We appreciate your continued patience and understanding.

November 8, 2025 · 08:58 PST
Investigating

We are currently experiencing limited access to the BlueSnap Merchant Console when using the latest version of the Google Chrome browser.

Our R&D team is actively investigating the issue and working to implement a fix as soon as possible.

In the meantime, we recommend using an earlier version of Chrome or an alternative browser (such as Firefox, Edge, or Safari) to ensure full access to the Merchant Console.

We appreciate your patience and understanding while we work to resolve this issue.

November 8, 2025 · 07:21 PST

← Back