3D secure service disruption
Minor incident
Production Environment
- Production: BuyNow Hosted Pages
- Production: Web Services (API)
2024-09-22 04:00 PDT
· 3 hours, 2 minutes
Updates
Resolved
September 22, 2024 · 06:52 PDT
The issue affecting the 3D Secure flow has been resolved, and normal service functionality has been restored.
Investigating
September 22, 2024 · 06:28 PDT
During scheduled maintenance, we identified an isolated issue with the 3D Secure authentication flow, which may result in some transaction failures.
Our team is actively working on a resolution
← Back