LiveChat Service Interruption
Minor incident
BlueSnap Technical Support
2024-08-08 11:02 PDT
· 2 hours, 20 minutes
Updates
Resolved
August 8, 2024 · 13:21 PDT
The issue has been resolved by our LiveChat service provider. BlueSnap chat is now fully functional.
Monitoring
August 8, 2024 · 11:17 PDT
BlueSnap’s LiveChat service is currently unavailable. Our LiveChat service provider is experiencing technical issues and are actively investigating. We will continue to monitor the situation.
In the meantime, please reach out to BlueSnap support via email, merchants@bluesnap.com, or contact form https://bluesnap.zendesk.com/hc/en-us/requests/new?ticket_form_id=360000127087 where our agents are available to assist you.
← Back