BlueSnap Logo

Status Page

LiveChat Service Interruption

Minor incident BlueSnap Technical Support
2024-02-27 08:25 PDT · 2 hours, 52 minutes

Updates

Resolved

Our LiveChat service provider has resolved the issue and BlueSnap LiveChat is again fully functional.

February 27, 2024 · 11:14 PDT
Monitoring

BlueSnap’s LiveChat service is currently unavailable. Our LiveChat service provider is experiencing technical issues and are actively investigating. We will continue to monitor the situation.

In the meantime, please reach out to BlueSnap support via email, merchants@bluesnap.com, or contact form https://bluesnap.zendesk.com/hc/en-us/requests/new?ticket_form_id=360000127087 where our agents are available to assist you.

February 27, 2024 · 08:35 PDT

← Back