BlueSnap Logo

Status Page

Visa Network Issues Causing Declines or Latency for Some Visa Card Transactions

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2023-11-24 12:15 PST · 3 hours, 47 minutes

Updates

Resolved

The Visa Network issue is now resolved and Visa transaction success rates have returned to normal levels.

November 24, 2023 · 15:53 PST
Investigating

There is an incident impacting transaction authorizations on the Visa Network. Some transactions may be declined or experience latency when processing. Visa technical resources are working with a third party issuer to identify and resolve the issue.

November 24, 2023 · 14:20 PST

← Back