BlueSnap Logo

Status Page

Increased number of processing errors with local LatAm cards

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API) - Production: Subscription Manager
2023-10-03 05:49 PST · 5 hours, 18 minutes

Updates

Resolved

The issue has been fully resolved by our LATAM acquirer. Processing has returned to normal levels. RCA is underway.

October 3, 2023 · 11:04 PST
Issue

We have identified an increased number of processing declines across local LatAm cards, and an investigation has been opened with our LatAm acquirers.

October 3, 2023 · 05:49 PST

← Back