BlueSnap Logo

Status Page

Giropay technical issue

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API) Sandbox Environment - Sandbox: BuyNow Hosted Pages - Sandbox: Web Services (API)
2023-09-04 06:30 PDT · 1 week, 1 day, 17 hours, 23 minutes

Updates

Resolved

We will re-enable the GiroPay payment method once the issue is resolved by the service provider, which is expected on September 18th.

September 12, 2023 · 23:52 PDT
Investigating

Giropay payment service provider is currently experiencing technical issues.

As a result, we have temporarily disabled Giropay as an available payment method.

We are working to resolve the issue as soon as possible and will be providing further updates.

September 5, 2023 · 10:39 PDT
Investigating

Giropay payment service provider is currently experiencing technical issues.

As a result, transactions are failing before customers are redirected to the Giropay payment page for completion.

We are working to resolve the issue as soon as possible and will be providing further updates.

September 5, 2023 · 04:08 PDT

← Back