BlueSnap Logo

Status Page

Ongoing Issue with Dispute Document Uploads via Chargebacks911 Portal

Minor incident Production Environment - Production: SnapConsole
2023-05-24 11:51 PDT · 15 hours, 5 minutes

Updates

Resolved

The Chargebacks911 team has reported that the file upload issue is now resolved. We are still monitoring this issue - please let us know if you continue to encounter any problems with the Chargebacks911 Portal.

May 25, 2023 · 02:53 PDT
Monitoring

There is currently an issue with merchant’s ability to successfully upload dispute documents in the Chargebacks911 portal. Chargebacks911 is investigating and we are actively monitoring the situation. Updates will be provided as they become available.

May 24, 2023 · 11:51 PDT

← Back