BlueSnap Logo

Status Page

Login Issues to Chargeback911 Portal Link

Minor incident Production Environment - Production: SnapConsole
2023-05-23 10:15 PDT · 20 hours, 21 minutes

Updates

Resolved

The login issue to Chargebacks portal has been resolved and access to it has been fully restored.

May 24, 2023 · 06:35 PDT
Monitoring

BlueSnap partner, Chargebacks911, is currently experiencing issues on their site. This is causing login failures with the Chargeback link in the BlueSnap merchant portal. We are monitoring the situation and will provide updates as they become available.

May 23, 2023 · 10:49 PDT

← Back