Live Chat Service Provider Reporting Service Degradation
Minor incident
BlueSnap Technical Support
2023-03-07 12:30 PDT
·
3 hours, 56 minutes
Updates
Resolved
March 7, 2023 · 16:26 PDT
This issue has been resolved. Live chat services are restored.
Monitoring
March 7, 2023 · 15:22 PDT
Our live chat service provider is currently reporting degradation of services resulting in intermittent access issues to BlueSnap chat-based support.
← Back