BlueSnap Logo

Status Page

Hosted Payment Fields Returning JS Errors

Minor incident Production Environment - Production: Web Services (API) Sandbox Environment - Sandbox: Web Services (API)
2022-09-12 22:00 PDT · 3 hours, 14 minutes

Updates

Resolved

The shift in traffic routing allowed us to rectify the issue and prevent any further JS error.

The preliminary root cause analysis leads us to a conclusion that the issue was caused by unstable internet connection among US ISPs.

Our DevOps and IT team are currently working on additional enhancement and traffic routing optimization to prevent similar issues in the future.

September 13, 2022 · 01:14 PDT
Monitoring

We have identified a DNS issue affecting hosted payment fields functionality in some regions.

While our DevOps and R&D teams are working on a permanent fix, additional changes in traffic routing have been applied as a temporary measure to decrease the number of errors

September 13, 2022 · 00:00 PDT
Issue

We are getting indications from merchants reporting JS errors on our HPF solution. BlueSnap R&D is investigating the issue and we will follow up with an update as soon as we have more details.

September 12, 2022 · 23:07 PDT

← Back