BlueSnap Logo

Status Page

Excessive Number of Fraud Declined Transactions

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2022-05-18 08:31 PDT · 3 hours, 20 minutes

Updates

Resolved

A routine configuration update implemented by our fraud screening partner resulted in an excessive number of transactions being blocked over a 2.5-hour period. The issue was resolved at approximately 11:30 am EST.

May 18, 2022 · 11:51 PDT
Investigating

We are experiencing a higher than expected number of fraud declines coming from our fraud screening partner. We are working with them to identify and resolve the issue as quickly as possible. Please contact support for more details.

May 18, 2022 · 10:29 PDT

← Back