BlueSnap Logo

Status Page

Higher than normal decline rate from our Canadian acquiring Bank

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2022-05-09 10:39 PDT · 5 hours, 43 minutes

Updates

Resolved

The issue is now fully resolved with transaction success rates returning to normal levels.

May 9, 2022 · 16:22 PDT
Investigating

We are seeing higher than normal declines from our Canadian acquiring Bank. We are working with the Bank to troubleshoot and fix the issue.

May 9, 2022 · 12:34 PDT

← Back