BlueSnap Logo

Status Page

American Express Connectivity Issues

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2021-10-21 12:06 PST · 1 hour, 27 minutes, 51 seconds

Updates

Resolved

American Express connectivity issues are now resolved.

October 21, 2021 · 13:34 PST
Investigating
  • American Express is experiencing connectivity issues impacting ALL acquirers causing some Amex card transactions to fail.
  • We are monitoring the situation with Amex and will provide an update when the service is fully recovered.
October 21, 2021 · 12:12 PST

← Back