BlueSnap Logo

Status Page

Mastercard Service Interruption - Affecting 3D Secure

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2021-10-14 16:05 PST · 13 hours, 54 minutes, 40 seconds

Updates

Resolved

We received a confirmation from our 3DS service provider that the issue is now resolved and starting at 4:50 am PT, the 3D authentication success rates are back to normal.

October 15, 2021 · 05:59 PST
Investigating

In recent hours Mastercard customers are experiencing intermittent service interruptions with 3DS. This may affect BlueSnap shoppers as well, where transactions require 3DS authentication.

We are tracking the updates from Mastercard and our 3DS service provider in order to minimize the impact on our services.

We will deliver a follow-up message once we have more updates.

October 15, 2021 · 04:12 PST

← Back