BlueSnap Logo

Status Page

Live Chat Interruptions

Minor incident BlueSnap Technical Support
2021-03-04 06:45 PDT · 1 hour, 48 minutes, 38 seconds

Updates

Resolved

The Live Chat issue is now resolved, our team is available on chat as usual.

March 4, 2021 · 08:33 PDT
Investigating

Our Support-Chat service provider is currently experiencing technical problems and the chat support channel is unavailable.

Please use the Support contact form to send a ticket to our team or call us, we will answer your requests as soon as possible.

March 4, 2021 · 07:53 PDT

← Back