BlueSnap Logo

Status Page

Issue with one of our acquiring banks

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2023-03-14 07:42 PDT · 20 hours, 8 minutes

Updates

Resolved

We have received a confirmation from our acquiring partners that the issue on their end has been resolved and we already see significant decrease in errors on charge attempts.

March 15, 2023 · 03:50 PDT
Investigating

We are currently experiencing issues with one of our acquiring banks resulting in an increase in card transaction declines. In some cases you may see the error “SYSTEM_TECHNICAL_ERROR” returned in response to transaction attempts. We are working with the acquirer to identify and resolve the issue.

March 14, 2023 · 15:01 PDT

← Back