BlueSnap Logo

Status Page

MasterCard 3D secure authentication disruption

Minor incident Production Environment - Production: BuyNow Hosted Pages - Production: Web Services (API)
2022-11-30 01:05 PST · 5 hours, 10 minutes

Updates

Resolved

We have received MasterCard confirmation that 3D secure functionality has been fully restored across all regions, while we continue to monitor MasterCard transactions authentication.

November 30, 2022 · 06:56 PST
Update

3D secure authentication functionality has been restored in all regions, with the exception of India, we will follow up as soon as we have more updates.

November 30, 2022 · 02:32 PST
Update

We have received a confirmation that Mastercard has restored 3D secure functionality in some regions and continues to work on recovering the service globally.

November 30, 2022 · 01:39 PST
Issue

Mastercard Securecode has confirmed that they have turned off all 3D Secure processing for Mastercard transactions. The issue is being investigated and we will be providing regular updates to this issue as we receive them.

November 30, 2022 · 01:11 PST

← Back